back to AMGBA website home page or AMGBA Photo Gallery or AMGBA Club Blog
Subscribe in a reader


Join or renew today and receive a free t-shirt or tech CD, see details in the join the club section at www.mgclub.org!

Author Topic: No Electrics  (Read 1906 times)

0 Members and 1 Guest are viewing this topic.

september2015

  • Message Board Member not current AMGBA Club Member
  • **
  • Posts: 5
No Electrics
« on: September 13, 2015, 11:19:18 PM »
I recently bought my first MGB, a 1977. The car runs but I has no electrics on the car - no headlights, taillights, interior lights or gauges, but the oil pressure gauges is working.

Can you give me any suggestions? I was told to check the ignition switch, that changing it may solve my problems.

Eric Jordan
Ashland, Kentucky


Art

  • chfwrench
  • AMGBA Club Tech Staff
  • ****
  • Posts: 246
  • Memberhsip Number (if known):: 91-10014
  • MG information: '73 red B roadster
Re: No Electrics
« Reply #1 on: September 13, 2015, 11:32:24 PM »
That the oil pressure gauge works is not surprising, as it is a mechcanical, not electrical, in operation.

The ignition switch (the electrical part on the back side of the lock) is known to cause some issues, but it usually is not so selective.  It generally malfunctions on the starter only or gives you nothing, but there are instances where the contacts internally are worn or lose and can give you only partial function.  I would definitely check it and if you find it loose or corroded on the back side, it would be best to replace it.  Check all the connections at the plug (or bullets) under the dash as well.

Victoria British sells the switch assembly only for the 77 (p/n 0-315; $18.95), as does Moss Motors as an aftermarket item (p/n263-690; $25.95) which Moss specifically says it will fit both the original or aftermarket locks.  Both are for use with the plug-in connector under the dash.  There is a chance someone may have swapped it or, being an an early car, you might actually have the older bullet connector type. Make sure to check before you order.

Id look more at the fuse box and the connectors to it.  This a more known culprit for this type of selective failure, as they tend to losen connections from vibration or lose connectivity due to corrosion with age.  Checking and cleaning this costs little or nothing, so I might start there first.  Remember that if the box is the
culprit, you should consider replacing all the connections to it as well.

There are other areas to check, but Id start with these first and see where it goes. 

I hope that helps you.  Let me know what you find and how you make out.

Safety Fast!
Art Isaacs
Art Isaacs
AMGBA Tech Staff
chfwrench@aol.com


 

back to AMGBA website home page or AMGBA Photo Gallery or AMGBA Club Blog