back to AMGBA website home page or AMGBA Photo Gallery or AMGBA Club Blog
Subscribe in a reader


Join or renew today and receive a free t-shirt or tech CD, see details in the join the club section at www.mgclub.org!

Author Topic: Cooling fluid loss  (Read 718 times)

0 Members and 1 Guest are viewing this topic.

september2017

  • Message Board Member not current AMGBA Club Member
  • **
  • Posts: 13
Cooling fluid loss
« on: August 15, 2017, 09:45:09 PM »
Q:   Iím having a loss of cooling fluid after I drive the car.  The temperature gauge is in the normal area when running.  The dripping after I shut off the car is running from under the front of the block.  I lose about a quart at a time.  The reservoir is still full.  Has the water pump gone bad?  Thanks.

Karl Haldorson
Farmington, Minnesota

Art

  • chfwrench
  • AMGBA Club Tech Staff
  • ****
  • Posts: 246
  • Memberhsip Number (if known):: 91-10014
  • MG information: '73 red B roadster
Re: Cooling fluid loss
« Reply #1 on: August 15, 2017, 10:08:11 PM »
A:   May well be, but if the car is still running cool and not overheating, the pump itself may not really be bad.
Front of the block could be a number of things,so you'll first have to trace the actual source. 

First question  It's dumb, but did you check if it's from the overflow tube?  I was troubleshooting a mysterious loss of coolant.  Car ran cool, but would lose about a half quart over a days' drive. After a while, we found the radiator cap to be the culprit.  Put a new cap on and no more loss. Also, the core of the radiator itself might be leaking, even spraying back on the block, where it puddles under when sitting.  The radiator can be repaired, re-cored or outright replaced fairly easily.  

If it's definitely from the engine, I'd start by removing the fan, belts and pulley on the pump to give you a clearer view of the area where you say the coolant appears to be coming from. Look at the pump shaft and see if it's the seal that's leaking.  It is, change the pump.  Maybe it's just the water pump gasket that's leaking.  If this is the case, it's as much labor to remove and replace the old pump as to put a new one, so, unless it was recently replaced, I'd strongly suggest replacing it. 

Other issues could be the thermostat housing, gasket, hoses at the connections to the engine/radiator or, more ominous issues could be a leaking head gasket or freeze-out plug (these are steel an can corrode and leak). We won't talk about any cracks as yet.
Check for the source first and then plan your next steps.  If it's something other than the pump or radiator that you find and have any questions, please feel free to contact me at any time.

Safety Fast!
Art Isaacs
Art Isaacs
AMGBA Tech Staff
chfwrench@aol.com


 

†† back to AMGBA website home page or AMGBA Photo Gallery or AMGBA Club Blog