back to AMGBA website home page or AMGBA Photo Gallery or AMGBA Club Blog
Subscribe in a reader


Join or renew today and receive a free t-shirt or tech CD, see details in the join the club section at www.mgclub.org!

Author Topic: turn signals not working  (Read 6933 times)

0 Members and 1 Guest are viewing this topic.

daddy57

  • Message Board Member but not an AMGBA Club Member
  • *
  • Posts: 1
turn signals not working
« on: October 26, 2008, 07:41:25 PM »
Hi all, my wife has a 1979 mg midget that i can't get the turn signals to work even after replacing the T.S. switch and checking all the connections.
They worked once after installing the new T.S. switch and now nothing, 4 way flashers work along with all other lights and yes i did replace the flasher unit also for the turn signals.
Any ideas?
Thanks in advance,

Daddy57

Kimberly

  • Message Board Member but not an AMGBA Club Member
  • *
  • Posts: 3
Re: turn signals not working
« Reply #1 on: October 28, 2008, 02:16:50 AM »
Hi all, my wife has a 1979 mg midget that i can't get the turn signals to work even after replacing the T.S. switch and checking all the connections.
They worked once after installing the new T.S. switch and now nothing, 4 way flashers work along with all other lights and yes i did replace the flasher unit also for the turn signals.
Any ideas?
Thanks in advance,

Daddy57

Have you used a meter or test light to check the green wires going to the hazard switch for power?  Did you use a test light or meter to check the connections in the circuit?  Hazard switches are known to internally fail due to corrosion and prevent power from getting to the turn signal switch.  Many have had success disassembling the hazard switch, cleaning the contacts, and lubricating the contacts with dielectric grease.


 

   back to AMGBA website home page or AMGBA Photo Gallery or AMGBA Club Blog